Help Center

My Premium doesn’t work / is activated only on one device. Why?

Our database cannot recognise an active subscription associated with your account. Please follow these steps:

Is the device you purchased your Premium service with connected to your account? If you can see "Remove device from account" under the ‘Subscription & Account’ option then you are connected.

  1. If not, please connect the device to your account to save and transfer your purchased subscription. You can now enable Premium in additional apps (MeteoEarth or AlertsPro) and on multiple devices by: selecting a premium feature, tapping on the “Restore Premium” button and adding your account credentials.

  2. If yes, please disconnect the device from your account (via the option “Remove device from account”) then restart your device and register again (via the option “Register this device”).

  3. If none of the previous steps work please send the invoice of your in-app purchase to our support team.  Alternatively you can also provide us with a screenshot of the purchase history, which indicates the premium purchase.


Have more questions? Submit a request

Comments

  • Avatar
    Robert Haraldsen

    1) 5 day view not working.
    2) Account password will not be sent to me by mail on demand
    3) Seems I have purchased Premium access twice.
    Please advice.
    Regards, Robert Haraldsen
    Profero@online.no

  • Avatar
    Adrien Parrel

    I have premium account but i only see 1 day view.

    Thank you.

  • Avatar
    Martine Troch

    After Paying For 1 year premium, the app meteoearth is not working anymore .

Powered by Zendesk